CCH Axcess Update
Incident Report for Rightworks OneSpace Firm Premier
Resolved
Please continue to contact support if you have further issues.
Posted Jan 12, 2022 - 14:58 EST
Monitoring
Please continue to click update if prompted. This should only need to be done once per server. Our teams will be addressing fully overnight.
Posted Jan 12, 2022 - 10:27 EST
Investigating
We are aware that an update for CCH Axcess was released overnight. If you are prompted for an update after opening Axcess, please proceed with installing the update. If you cannot install the update or you continue to have issue after installing the update, please call support.
Posted Jan 12, 2022 - 08:50 EST