Microsoft 365 Services and Features: Degraded Performance
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 14:45 EDT
Update
Microsoft continues to actively monitor their service to ensure it remains in a healthy state. The status for this issue has been downgraded to an advisory at this time.
Posted Jun 08, 2023 - 08:31 EDT
Update
Microsoft reports they continue to observe stable service health and continue to closely monitor.
Posted Jun 07, 2023 - 08:21 EDT
Update
Microsoft reports their engineering team remains focussed on maintaining service stability and they continue to investigate the degraded performance for some Microsoft services and features.

Scope of impact: Users routed through the affected infrastructure are affected by this issue, however, impact can vary depending on where users are hosted.
Posted Jun 06, 2023 - 21:01 EDT
Update
Microsoft has deployed a change to provide greater stability across their services, however, this has not fully resolved the issue. They continue to investigate and work to remediate overall impact.

Scope of impact: Users routed through the affected infrastructure are affected by this issue, however, impact can vary depending on where users are hosted.
Posted Jun 06, 2023 - 13:45 EDT
Update
Microsoft has reported that they are again seeing impact to various Microsoft services and features affecting users routed through the affected infrastructure. They are working to apply further mitigations at this time.
Posted Jun 06, 2023 - 12:13 EDT
Update
Microsoft reports that after applying mitigations, they are seeing availability return to healthy levels as they continue to monitor performance of the affected infrastructure. We will continue to relay further updates from Microsoft as we have them.
Posted Jun 06, 2023 - 11:57 EDT
Update
We will continue to monitor and relay updates from Microsoft regarding degraded performance for some Microsoft applications and services affecting users routed through their affected infrastructure.
Posted Jun 06, 2023 - 07:48 EDT
Update
Microsoft has reported some improvement related to performance issues for features and services impacting users routed through affected infrastructure. They remain focused on investigating and addressing the root cause of the issue.
Posted Jun 05, 2023 - 20:52 EDT
Monitoring
Microsoft has reported degraded performance for some Microsoft services and features. Users routed through the affected infrastructure could experience issues with Microsoft applications and/or see delays with Microsoft services. We will relay further updates from Microsoft as able.
Posted Jun 05, 2023 - 17:15 EDT