Thomson Reuters Authenticator
Incident Report for Rightworks OneSpace Firm Premier
Resolved
For any further information please review Thomson's status or connect with their support.
Posted Oct 18, 2021 - 09:10 EDT
Monitoring
Please note we have been made aware of an issue with iPhone users authenticating with Thomson Reuters products. Please see the page below for more details from Thomson.

https://taxprofessionals-status.hostedtax.thomsonreuters.com/incidents/2v32bkydgv3r
Posted Oct 14, 2021 - 09:14 EDT