CCH Axcess
Incident Report for Rightworks OneSpace Firm Premier
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 16:19 EST
Identified
Clients are reporting 502 Server Error when attempting to use Axcess products. CCH is aware and working on this issue.
Posted Nov 17, 2021 - 12:57 EST